TOP » 操作・設定 » 操作全般 » 3Dに関する操作 » 3Dモデリング » 【VariCAD実演】3次元CAD利用技術者試験1級・準1級 サンプル問題 問1設問3

【VariCAD実演】3次元CAD利用技術者試験1級・準1級 サンプル問題 問1設問3

「3次元CAD利用技術者試験1級・準1級」のサンプル問題(実技)について、モデリングの手順から解答までのプロセスをVariCADを使って徹底解説します。本ページでは問1の設問3に解答します。

引用元:ACSP(コンピュータ教育振興協会)公式サイト

<<問1 設問2へ戻る

⑫ソリッドモデルHを無限平面Bで切断し、体積の小さい方のソリッドモデルを除去しなさい。これをソリッドモデルIとする。

  1. VariCAD では、無限平面 B とする点Q(60,0,50)と点R(0,100,25)と点S(60,100,25)を通る平面を持つ、切り取りソリッドを作成し、除去します。まず、メニューバーの「オブジェクト」>「一般的な論理演算」>「押出ソリッドによる切り取り」をクリックします。     押出ソリッドによる切り取り
  2. ソリッドHをクリックで選択します。                   ソリッドの選択
  3. 「スケッチ平面の定義」ウィンドウで、「3点によるスケッチ平面」をクリックします。スケッチ平面の設定 
  4. 「3Dスナップ」ツールバーの「XYZ」アイコンをクリックします。XYZアイコン  
  5. 「絶対座標」ウィンドウで点Q(60,0,50)の位置、「X座標」に60、「Y座標」に0、「Z座標」に50を入力し、「OK」をクリックします。                        座標の入力
  6. 「3Dスナップ」ツールバーの「XYZ」アイコンをクリックします。 XYZアイコン
  7. 「絶対座標」ウィンドウで点R(0,100,25)の位置、「X座標」に0、「Y座標」に100、「Z座標」に25を入力し、「OK」をクリックします。                        座標の入力
  8. 「3Dスナップ」ツールバーの「XYZ」アイコンをクリックします。 XYZアイコン 
  9. 「絶対座標」ウィンドウで点S(60,100,25)の位置、「X座標」に60、「Y座標」に100、「Z座標」に25を入力し、「OK」をクリックします。                               座標の入力
  10. 点Q(60,0,50)と点R(0,100,25)と点S(60,100,25)を通る描画平面が設定されます。 描画平面の設定
  11. 次に、描画平面に押出ソリッドのプロファイルとなる長方形を描きます。「長方形」アイコンをクリックします。                                                       長方形アイコン
  12. ソリッドモデルHを覆うように長方形を描きます。Escキーを押して描画を終了します。                      長方形の描画 描画の終了
  13. 横から見ると下図のようになります。太線部分が、無限平面Bとなる切断面となります。ソリッドモデルHを無限平面Bを境に、体積の小さい方(赤色の点線枠内部分)のソリッドモデルを除去するので、Z軸の矢印方向とは反対方向に押し出して切り取りソリッドを作成します。    切り取りソリッドの作成
  14. 「ソリッドプロファイル作成」ツールバーの赤字の「OK」アイコンをクリックします。OKアイコン 
  15. 「押出」ウィンドウでソリッドの高さ欄に、Z軸の矢印方向とは反対方向に押し出して切り取りソリッドを作成するので、値の前に負の符号マイナスをつけて、-150と入力します。「OK」をクリックします。                                               切り取りソリッドの高さ入力
  16. Escキーを押して終了します。ソリッドモデルIが作成できました。                    ソリッドの作成完了 ソリッドの作成完了

⑬XY平面上において、点W(50,100,0) を中心点に持つ半径100mm の円を作成しなさい。
これを円Jとする。

⑭円Jを、Z軸の正方向に60mm、負方向に60mm 押し出してソリッドモデルを作成しなさい。
これをソリッドモデルKとする。

  1. VariCAD では、円Jを1面にもつ高さ60mm の円筒ソリッドを作成し、円Jを鏡像面として反転複写し、2つの円筒ソリッドを結合して、ソリッドモデルKを作成します。                                                          まず、描画平面をXY平面にします。描画画面左下のXYZ軸をクリックで選択します。 描画平面の設定 
  2. 「空間XY軸によるスケッチ平面」をクリックで選択します。 スケッチ平面の選択
  3. メニューバーの「表示」>「ビューに対して垂直なスケッチ平面」をクリックで選択します。   ビューの切り替え
  4. 次に円を描きます。メニューバーの「オブジェクト」>「描画」>「円弧と円」>「円の中心、半径」をクリックで選択します。                             円の中心、半径 
  5. 円の中心点の位置を指定します。「スナップ、ポップアップ」ツールバーの「XY座標」アイコンをクリックします。                            XY座標
  6. 「X座標」欄に50、「Y座標」欄に100を入力します。「OK」をクリックします。座標の入力
  7. 「円の半径」欄に100を入力し「OK」をクリックします。          円の半径の入力
  8. 円が描かれます。                                                              円の描画
  9. 「OK」をクリックします。                                                                            OK
  10. 「選択した2Dプロファイルをソリッドに押出し」をクリックで選択します。 プロファイルの押出
  11. 「押出」ウィンドウで「ソリッドの高さ」欄に60を入力します。「X軸の向きを定義する」のチェックは外します。「押し出すプロファイルを選択」をクリックします。                                高さの入力
  12. 円をクリックで選択します。右クリックで選択を終了します。プロファイルの選択  
  13. ソリッドの挿入ポイントを円の中心位置に指定します。「スナップ、ポップアップ」ツールバーの「中心」アイコンをクリックします。                                  挿入ポイントの設定
  14. 円をクリックします。                                                                円の選択 
  15. 円筒ソリッドが仮挿入されます。右クリックで挿入します。  円筒ソリッドの仮挿入 円筒ソリッドの挿入 
  16. 次に円筒ソリッドを反転複写します。 メニューバーの「編集」>「反転複写」をクリックで選択します。                             反転複写
  17. 「平面の選択」をクリックで選択します。平面の選択
  18. 円をクリックで選択します。                                                  円の選択
  19. 円筒ソリッドをクリックで選択します。右クリックで選択を終了します。 円筒ソリッドの選択
  20. 円筒ソリッドが反転複写されました。 Escキーを押して終了します。                 反転複写の完了 
  21. 次に2つの円筒ソリッドを結合します。反転複写で作成した円筒ソリッドを右クリックで選択します。                                ソリッドの結合
  22. 表示されるオプションから「論理演算」>「ソリッドへ追加」をクリックで選択します。ソリッドへ追加
  23. コピー元の円筒ソリッドをクリックで選択します。                    ソリッドの選択
  24. 2つの円筒ソリッドが結合しました。ソリッドモデルKを作成できました。                                                 ソリッドの結合完了

⑮ソリッドモデルIとソリッドモデルKの積となるソリッドモデルを作成しなさい。

  1. 3D CADにおける「ソリッドの積」とは、複数の立体(ソリッド)が重なり合っている共通部分(交差部分)だけを抽出して新しい立体を作る操作です。VariCADでは、論理演算機能の交差を使用して、積となるソリッドを作成します。まず、メニューバーの「オブジェクト」>「論理演算」>「交差」をクリックで選択します。交差
  2. ソリッドKをクリックで選択します。                             ソリッドの選択
  3. ソリッドIをクリックで選択します。                                             ソリッドの選択
  4. 交差部分以外が除去され、ソリッドモデルIとソリッドモデルKの積となるソリッドモデルを作成できました。Escキーを押して終了します。                                          交差の完了 ソリッドの作成完了

⑯【設問3】に解答しなさい。

【設問3】
完成モデルの体積値および重心の座標値を計測し、もっとも近いものを解答群より1つ選び、
解答記入欄に〇を付けなさい。
なお、重心はモデリングした座標系の頂点を基準として計測すること。

解答群(体積値および重心座標値)
[1]1.151×10⁶ X:4.191×10 Y:8.917×10 Z:-7.871
[2]1.151×10⁶ X:4.196×10 Y:8.924×10 Z:-7.835
[3]1.153×10⁶ X:4.196×10 Y:8.924×10 Z:-7.835
[4]1.153×10⁶ X:4.203×10 Y:8.930×10 Z:-7.799
[5]1.156×10⁶ X:4.203×10 Y:8.930×10 Z:-7.799

  1. メニューバーの「オブジェクト」>「ソリッドの計算」>「体積、質量、重心」をクリックで選択します。                                                   体積、質量、重心
  2. ソリッドをクリックで選択します。                             ソリッドの選択
  3. 右クリックで選択を終了します。                                   選択の終了
  4. 「体積の計算」ウィンドウで計算結果が表示されます。解答群より、値が最も近い、[4]が正解となります。                                                                                                                                                          CAD利用技術者試験
体積の計算結果