TOP » 操作・設定 » 組立図へ部品リストを追加・配置する方法は?

組立図へ部品リストを追加・配置する方法は?

部品リストを挿入するには、予め、ソリッドに属性を設定し、組立部品のファイルの2D図面に部品表の枠線を描いておく必要があります。属性を設定する方法は、属性をソリッドに設定する方法をご覧ください。また、部品リストを挿入する頻度が多い場合は、タイトルブロックのテンプレートに部品表の枠線を描画しておくと便利です。タイトルブロックの登録方法は、オリジナルのタイトルブロックを登録したいをご確認ください。

  1. 下図の様な部品表の枠線が描かれたタイトルブロックのテンプレートファイルを開くか、組立部品のファイルの2D図面に枠線を描きます。枠線が用意できた後、部品表に挿入する、ソリッドの属性の値の配置位置を設定していきます。タイトルブロックのテンプレート
  2. メニューバーの「オブジェクト」>「属性およびタイトル・ブロック」>「BOM、属性およびタイトル・ブロックの設定」をクリックで選択します。 BOM、属性およびタイトル・ブロックの設定
  3. 「表へ」の欄に、部品リストに出力するかどうかが表示されています。部品リストに出力するアイテム
  4. 部品表に挿入したい属性をクリックで選択します。「属性を編集」をクリックで選択します。属性の編集
  5. 「属性を編集します」ウィンドウの左側ツリー項目で「表への出力-部品のリスト」をクリックで選択します。                                     表への出力-部品のリスト
  6. ウィンドウ右側に表示される「属性を表に印刷する」オプションにチェックを入れます。   属性を表に印刷する
  7. 「2D領域にオフセットされる行を設定」をクリックします。 オフセットされる行を設定
  8. 1行目の左下角をクリックします。                     配置設定  
  9. 2行目の左下角をクリックします。   配置設定
  10.  「はい」をクリックします。                  配置設定完了
  11. 「2D領域の文字列の位置を設定」をクリックします。   属性の配置設定
  12. 挿入したい属性の配置位置でクリックします。属性の配置設定
  13. 描画画面左下に表示されるステータスバーで、右縁と表示されている場合は値を挿入するセルの右下端をクリックします。左縁と表示される場合はセルの左下端をクリックします。属性の配置設定
  14. 「属性を編集します」ウィンドウに戻り、「OK」をクリックします。    属性の編集完了
  15. 挿入したくない属性の場合は、挿入したい属性をクリックで選択します。「属性を編集」をクリックで選択します。                               属性の編集
  16. 「属性を編集します」ウィンドウの左側ツリー項目で「表への出力-部品のリスト」をクリックで選択し、ウィンドウ右側に表示される「属性を表に印刷する」オプションのチェックを外します。                         属性を表に印刷
  17. 「OK」をクリックします。                                属性の設定完了""
  18. 続けて、部品表に挿入したい属性をクリックで選択します。「属性を編集」をクリックで選択します。                  属性の編集
  19. 「属性を編集します」ウィンドウの左側ツリー項目で「表への出力-部品のリスト」をクリックで選択し、ウィンドウ右側に表示される「属性を表に印刷する」オプションにチェックを入れます。                                                  表への出力-部品のリスト
  20. 「2D領域の文字列の位置を設定」をクリックします。属性の配置設定
  21. 挿入したい属性の配置位置でクリックします。属性の配置設定
  22. 描画画面左下に表示されるステータスバーで、右縁と表示されている場合は値を挿入するセルの右下端をクリックします。左縁と表示される場合はセルの左下端をクリックします。属性の配置設定
  23. 「属性を編集します」ウィンドウに戻り、「OK」をクリックします。  属性の配置設定完了
  24. 「OK」をクリックします。                                                                           属性の配置設定完了
  25. ファイルを上書き保存します。 タイトルブロックのテンプレートファイルに設定した場合は、ファイルを一旦閉じます。                                                       ファイルの上書き保存
  26. タイトルブロックのテンプレートファイルに設定した場合は、部品表を挿入したい組立部品ファイルを開き、タイトルブロックを挿入します。メニューバーの「オブジェクト」>「属性およびBOM」>「基本レベルでBOMを作成」をクリックで選択します。BOMレベルの選択
  27. 「ファイルへ出力」をクリックします。                             ファイルへ出力
  28. 「部品のリスト(2D)」をクリックで選択します。部品リスト
  29. 部品表の1行目の左下角をクリックします。部品表の配置
  30. 部品表の最後の行の左下角をクリックします。 部品表の配置
  31. 下図のメッセージが表示された場合は、「OK」をクリックします。確認メッセージ
  32. 「OK」をクリックします。                   部品表の挿入
  33. 部品表が挿入されました。部品表の挿入完了